VERICUT Users' Forum

Due to relentless spammers, we are no longer automatically accepting new forum registrations. If you wish to register for this forum, please send an e-mail to:

You are not logged in.

#1 2007-02-23 16:03:05

VERICUT Specialist
From: Irvine, CA
Registered: 2004-10-08
Posts: 146

internalError: Unable to bind ... possible solution

A possible solution exists for the “Unable to bind” error that has been floating around for a couple of years. We have solved it for one customer. The production fix will be in 6.1.1.


An error message displays when opening a file selection box and browsing to a folder, usually located on a network disk. The message starts with “internalError: Unable to bind ...”. The error is caused by a failed request between Java and Windows. VERICUT is simply displaying the error. When the error occurs the file selection box cannot be used and must be closed. Some of you may have worked-around this error by replacing the Java file selection box with a Windows file selection box via the env var CGTECH_OLD_FSB.

This Specific Case

In this case, the customer began seeing the error after their IT department installed a series of security measures on end-users’ computers. The error typically only occurred when browsing to a folder in “Network Neighborhood”, such that the file path was expressed using the Universal Naming Convention (UNC) format. If the exact same location was referenced with a mapped drive letter then the problem did not occur. However on a few computers even the mapped drive letter failed.

Unfortunately, the company’s IT department could not or would not divulge what was in the security updates.

The Solution

After a few days of testing and attempted fixes we discovered a solution. However we’re not sure if the implementation is supported on UNIX platforms. This is not a UNIX problem, but we have one code-base that is used on all platforms, UNIX and Windows.

Applying the Solution to Others

CGTech is unable to duplicate this problem. We do not know the root-cause of the problem, and may likely never know. So it is impossible to tell if this solution is generally applicable to other instances of the same error. If the same error has a different root-cause, it is possible this solution will not fix it.


A production fix will be in 6.1.1.

A preliminary fix can be delivered that works in 5.4.x, 6.0.x, and 6.1. Files containing the fix are available from CGTech technical support.

The fix applies to Windows platforms only.


Board footer